Results 1 to 4 of 4

Thread: 328 Heater wiring problem, 328 electrical expert required!!

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Aug 2007
    Location
    Burton On Trent
    Name
    Darren
    Posts
    39

    Default 328 Heater wiring problem, 328 electrical expert required!!

    I have a problem on the wrining on my 328, on the passenger side the heater controls do not work. I did know when I brought the car but thought it was the switch, I have checked the switch and motorised valves and they work.

    If I run some cable from the connector in the tunnel to the valve motor it works fine so there must be a break in the wire or a plug some where that I don't know about.

    Does any body have any ideas, its very hard to see where the cables go I am guessing that there is a plug I haven't found or the wire has been cut by acciendent (maybe when an alarm was fitted)

    Has anybody got any ideas.
    Last edited by Das; 12-11-2007 at 01:09 AM.

  2. #2
    Iain is offline Overpriced piece of old tat - Ferrari 250 GTO Club Member
    Join Date
    Nov 2005
    Location
    .
    Name
    Iain
    Posts
    7,173

    Default

    Quote Originally Posted by Das View Post
    I have a problem on the wrining on my 328, on the passenger side the heater controls do not work. I did know when I brought the car but thought it was the switch, I have checked the switch and motorised valves and they work.

    If I run some cable from the connector in the tunnel to the valve motor it works fine so there must be a break in the wire or a plug some where that I don't know about.

    Does any body have any ideas, its very hard to see where the cables go I am guessing that there is a plug I haven't found or the wire has been cut by acciendent (maybe when an alarm was fitted)

    Has anybody got any ideas.
    Brrrrrrrr 20 year old Ferrari electrics I'm afraid I can't be of any help, everything in mine works (touch wood) & so I havn't really had to delve into that area

  3. #3
    Join Date
    Aug 2007
    Location
    Burton On Trent
    Name
    Darren
    Posts
    39

    Default

    Now fixed.
    Bad contact on connector behind fuse/relay board.
    Took some finding!!.

  4. #4
    Iain is offline Overpriced piece of old tat - Ferrari 250 GTO Club Member
    Join Date
    Nov 2005
    Location
    .
    Name
    Iain
    Posts
    7,173

    Default

    Quote Originally Posted by Das View Post
    Now fixed.
    Bad contact on connector behind fuse/relay board.
    Took some finding!!.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •